Errors with 'gensky' and 'oconv' not recognised commands

Forum for users to discuss the DesignBuilder Radiance daylighting tools and ask questions

Moderator: DesignBuilder Support

Posts: 3

Errors with 'gensky' and 'oconv' not recognised commands

Postby doctorsushi » Sun Apr 22, 2012 1:02 am


I've just started trying to use DB for daylighting for the first time, so my hunch is that this is a setup/install problem but:

When going to a daylight sim I get the option window OK, then when I click go I get: 'gensky not recognised internal or external command' error box. The same with 'oconv'.

I recognise these commands from working with Radiance, but I guess DB isn't talking to Radiance properly?

I'm using DB on WinXP, though I'll try on Win7 and see if the same thing pops up...

Thanks in advance.
Andy Tindale
Posts: 2669
Location: Stroud

Postby Andy Tindale » Mon Apr 23, 2012 10:55 am

There are 2 known causes of this problem but usuallly it can be resolved using instructions under 1 below:

1. Failure in the installation of the Radiance software. You can check to see if this is the cause by going to the DesignBuilder Radiance folder ("File > Folders > Radiance folder" menu command opens the folder in Windows Explorer). If you see folders "rlib" and "bin" then Radiance has installed correctly. If not then you should be able to manually install Radiance by copying the file "C:\Program files\DesignBuilder\Radiance\" to the above Radiance folder and extract it there. After the extraction you should have the "rlib" and "bin" folders below the DesignBuilder Radiance folder and Radiance should now run.

2 Less commonly the problem is caused by the encoding the command prompt is using. It may be a using a different encoding to VB6 so certain of the characters were being misinterpreted leading to an attempt to cd to a non-existent folder. In this case the solution is to:

1.Set the font of the command window to Lucida Console, making sure it is set for all future invocations.

2.Set the code page for the command prompt to 1252, not the default 850. To do this set the value of OEMCP in the key
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Nls\CodePage to 1252

Posts: 3

Postby doctorsushi » Thu Apr 26, 2012 1:45 am

Thanks Andy,

Option Two was the fix in my case.

Return to “Radiance Daylighting”

Who is online

Users browsing this forum: No registered users and 1 guest